Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - ababilinski

Pages: [1]
1
NGUI 3 Support / Re: UIToggle Not Changing value
« on: June 10, 2014, 07:41:05 AM »
Also if I use a code like this

  1.         public bool turnOn;
  2.  
  3.         // Update is called once per frame
  4.         void Update () {
  5.                 if(turnOn == false){
  6.                 gameObject.GetComponent<UIToggle>().value = false;
  7.                 }
  8.  
  9.                 if(turnOn == true){
  10.                         gameObject.GetComponent<UIToggle>().value = true;
  11.                 }
  12.         }

then it will turn on using
  1. gameObject.GetComponent<UIToggle>().value = true;

but it will not turn off even when turnOn = false.

This also only happens when there is a group assigned.

2
NGUI 3 Support / Re: UIToggle Not Changing value
« on: June 10, 2014, 07:36:08 AM »
Quote
Where is this code getting called from? Also define "not working"? Do you even see the Debug.Log?

the function is being called in another codes update function. Sorry for my vagueness.

The problem that is happening is that the value is not changing. I added a debug to see the current value and it is set to true. no mater what I do.

3
NGUI 3 Support / UIToggle Not Changing value
« on: June 09, 2014, 11:12:17 PM »
  1. public void RestState(){
  2.                 if(CurButton != null){
  3.                  UIToggle _UI = CurButton.GetComponent<UIToggle>();
  4.                 if( _UI != null){
  5.                        
  6.                         CurButton.GetComponent<UIToggle>().value = false;
  7.                         Debug.Log(CurButton.GetComponent<UIToggle>().value);
  8.  
  9.                 }
  10.         }
  11. }
I am using this code above and I don't know what I am doing wrong. I get the code and a bool is supposed to set the value of the check-box back to false. However, It is not working.

4
I figured out the problem now. NGUI does not support GLES 3. Got it fixed now! thank you!

5
Quote
Whenever clipping doesn't work, it means the appropriate shader was not loaded. This can be caused by running the game using the "Fastest" quality setting, targeting GLES 1.1 / ARMv6, or by moving NGUI's shaders out of their proper place in the Resources folder.

I have the Shaders in in the Resources folder.
I disabled the fastest quality setting.
I also my device filter is ARMv7 Only.

6
The scroll view does not clip the objects when the user is scrolling through the view. The scroll view works perfectly but seems to fail when exported.
 
here is a link to a screen recording taken off of my phone.
https://drive.google.com/file/d/0B9LpK1sHpGZ-TEVReko3cEFTMF84V0FyNnRMdTZHcTBESTFF/edit?usp=sharing


I'm running version :3.6.1
I'm exporting to Android 4.2 or higher which supports higher quality textures.

7
NGUI 3 Documentation / Re: UIButton
« on: May 25, 2014, 12:39:30 PM »
To all who want to access the notify field in another script  :D! You gave to add an EventDelegate.
  1. EventDelegate Event = new EventDelegate();
  2. Event.set("The Code You Want To Set","The Function You Want To Call(As A String")
  3. UIButtonObject.GetComponent<UIButton>().onClick.Add(Event);
  4.  

Hope it helps people,
ababilinski :)

Pages: [1]