Support > NGUI 3 Support

2D UI Zooming on click

(1/2) > >>

neopickaze:
Hey all,

I'm having some problems working with the sample files on Unity 5.5 running on my 5K retina imac

Whenever I click or scroll the mousewheel or interact in anyway all the 2D components are zoomed in and overscaled which usually means I can't click any of the buttons.

3D seems to be unaffected, apologies if I'm missing some silly configuration to get this to work:

Here's a video showing the behavior
https://www.youtube.com/watch?v=0JCyfFo_ptk

Thanks for your help

neopickaze:
Sorry for double post forgot to add it's NGUI 3.11.1 and I think I'm having this same problem as this guy was:

http://www.tasharen.com/forum/index.php?topic=14748.0

neopickaze:
Triple posting now - sorry can't edit :)

Tried the advice in here removing the #ifdef completely, uncommenting the if on line 1959 and nothing seems to make a difference
https://www.tasharen.com/forum/index.php?topic=15015.0

I appreciate it's a unity bug not an NGUI bug, I'll keep playing but any advice in the meantime appreciated :)

neopickaze:
OK forget what I said earlier, it was already commented out in this version 3.11.1 - if I re-enable it all it's better

#if UNITY_EDITOR_OSX                                        // There seems to be a Unity 5.4 bug that returns invalid screen size when the mouse is clicked (wtf?) on OSX                                        if (mGameSize.x == 1f && mGameSize.y == 1f) mGameSize = s_GetSizeOfMainGameView();#else                                        mGameSize = s_GetSizeOfMainGameView();#endif

ArenMook:
Please report it as a bug to Unity so they can fix it properly. This hack of mine has side effects.

Navigation

[0] Message Index

[#] Next page

Go to full version