Author Topic: Font Maker crash issue with Unity 5.3  (Read 830 times)

thedoor2009

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Posts: 1
    • View Profile
Font Maker crash issue with Unity 5.3
« on: February 26, 2016, 05:47:55 PM »
So for our current project, we want to create a new NGUI bitmap font according to the requirement. In order to do that, we need to use the font maker to create the atlas for the new font. Unluckily, right now every time we open the font maker, when we select one font, the whole project would crash. I have searched for the solutions but there are a few similar situations online. Also I have tried using Unity 5.2 to see whether the old version could work, but it still crashed.

Is there any solution could fix this problem? Thank you!

ArenMook

  • Administrator
  • Hero Member
  • *****
  • Thank You
  • -Given: 337
  • -Receive: 1171
  • Posts: 22,138
  • Toronto, Canada
    • View Profile
Re: Font Maker crash issue with Unity 5.3
« Reply #1 on: March 01, 2016, 06:10:09 AM »
You will need to elaborate, as it works fine here. I can understand the font maker displaying an error on OSX 64-bit Unity as there is no 64-bit font dylib, but the 64-bit version of Unity works just fine in Windows. Are you running a 32-bit version?

schedal

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Posts: 1
    • View Profile
Re: Font Maker crash issue with Unity 5.3
« Reply #2 on: May 31, 2017, 10:45:57 AM »
I have the exact same issue, is there any fix for this?

Steps to reproduce:

1. Import NGUI v3.11.3
2. Launch Font Maker
3. Select a font
4. Unity3D crashes

ArenMook

  • Administrator
  • Hero Member
  • *****
  • Thank You
  • -Given: 337
  • -Receive: 1171
  • Posts: 22,138
  • Toronto, Canada
    • View Profile
Re: Font Maker crash issue with Unity 5.3
« Reply #3 on: June 05, 2017, 03:53:27 AM »
Same steps work as expected. What version of Unity? What operating system? Some key details are still missing in this thread. If it's really Unity 5.3 then there isn't much I can suggest as the latest NGUI doesn't support 5.3 anymore. You will need an older version of NGUI that corresponds to an older version of Unity.