Author Topic: TNet 3 and Unity 2017  (Read 750 times)

t4interactive

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Posts: 4
    • View Profile
TNet 3 and Unity 2017
« on: October 20, 2017, 07:27:38 PM »
Hello everyone,

We are considering in buying TNet (one of our developers already used in the past at it looks really good).
Does it work with Unity 2017.2 already? We did not find this info in the releases.
Also, how many known issues do you have (we all have known issues, lol).

Thank you in advance.

ArenMook

  • Administrator
  • Hero Member
  • *****
  • Thank You
  • -Given: 337
  • -Receive: 1171
  • Posts: 22,149
  • Toronto, Canada
    • View Profile
Re: TNet 3 and Unity 2017
« Reply #1 on: November 06, 2017, 07:38:13 AM »
TNet doesn't have a deep integration with the editor like NGUI does, so I don't think there should be any issues. I haven't heard of anything either, but I'm using 5.6 for the current project myself.

t4interactive

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Posts: 4
    • View Profile
Re: TNet 3 and Unity 2017
« Reply #2 on: November 07, 2017, 10:06:35 AM »
Thanks for the reply Aren.
So, you are not sure if it works at all in Unity 2017.2?
« Last Edit: November 07, 2017, 10:23:20 AM by t4interactive »

t4interactive

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Posts: 4
    • View Profile
Re: TNet 3 and Unity 2017
« Reply #3 on: November 07, 2017, 11:01:07 AM »
Nevermind, we will just bought since the costs are good and will test on our own =)
Thanks

ArenMook

  • Administrator
  • Hero Member
  • *****
  • Thank You
  • -Given: 337
  • -Receive: 1171
  • Posts: 22,149
  • Toronto, Canada
    • View Profile
Re: TNet 3 and Unity 2017
« Reply #4 on: November 07, 2017, 05:03:47 PM »
If you run into any issues, just let me know.

cmifwdll

  • Global Moderator
  • Sr. Member
  • *****
  • Thank You
  • -Given: 0
  • -Receive: 149
  • Posts: 285
  • TNet Alchemist
    • View Profile
Re: TNet 3 and Unity 2017
« Reply #5 on: November 07, 2017, 11:47:40 PM »
I make tiny little projects when helping people with issues on here. None of them fully utilize TNet, but all of them are on 2017.1.1 and I haven't ran into any problems yet.

To ArenMook: Unity 2017 comes with a runtime upgrade. Apparently up to .NET 4.6 & C#6.0. The old runtime is still default, though.

t4interactive

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Posts: 4
    • View Profile
Re: TNet 3 and Unity 2017
« Reply #6 on: November 09, 2017, 07:21:49 PM »
Thank you both.
I can already say that it is working on 2017.2 with no problems at all.

Cheers

ThreadLok

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Posts: 2
    • View Profile
Re: TNet 3 and Unity 2017
« Reply #7 on: January 18, 2018, 07:12:22 PM »
Just to wrap this thread off, I've been using TNet with 2017.3 and there doesn't seem to be anything blocking.