Author Topic: [SOLVED] Very annoying: can't move when focus on widget  (Read 1429 times)

vexe

  • Full Member
  • ***
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Posts: 153
    • View Profile
[SOLVED] Very annoying: can't move when focus on widget
« on: October 27, 2013, 10:14:30 AM »
I was really hopping this would come to an end when I upgraded to 3.0.2 but obviously it's not.

If I click on a widget (say sprite) and press F to focus on it, I can't move, I can't do anything, no Right click navigating with the mouse, no WASD editor movement, etc. The only way to free myself is to unselect the widget - Select something otherwise, something that's not a widget.

Am I missing something? or this is just the way it is... ? :(
« Last Edit: October 28, 2013, 01:10:33 AM by vexe »

ArenMook

  • Administrator
  • Hero Member
  • *****
  • Thank You
  • -Given: 337
  • -Receive: 1171
  • Posts: 22,128
  • Toronto, Canada
    • View Profile
Re: Very annoying: can't move when focus on widget
« Reply #1 on: October 27, 2013, 10:44:13 PM »
Why would you right click? This pans the camera. Majority of the UI design is done on a flat plane -- that is two-dimensional. Panning is done in 3D. Same goes for WASD. It's for 3D navigation, and UI design is done in 2D. If you really miss that functionality, use Alt+LMB instead.

Use the middle mouse button to move around instead. This moves the camera along the plane it's on.