Author Topic: Tasharen Fog of War Unity 5.0 Question  (Read 3795 times)

Velo

  • Newbie
  • *
  • Thank You
  • -Given: 1
  • -Receive: 2
  • Posts: 13
    • View Profile
Tasharen Fog of War Unity 5.0 Question
« on: November 17, 2014, 01:04:32 AM »
Hey Aren,

I'm currently in the Unity 5.0 beta, and I'm using your Fog of War package in my project right now.  I noticed that when I had the "DX11" option checked in the player settings, I was getting pretty big performance spikes while playing my game (in 5.0).  I did not get these spikes when using Unity 4.x with the DX11 option checked.  Here's the thing though, I have a graphics card that only supports up to DX10!  So I'm not sure what's causing the performance lag spikes.  Again, in Unity 4.x there was no problem.  Now in Unity 5.0 beta, there is a problem.  My guess might be the new lighting system doing something or the physically based shaders, but that's just a guess on my part.

Using Unity 5.0 currently, if I unselect DX11 in player settings, and just use DX9, the lag spikes go away.  Which is great, but I was hoping there wouldn't be any lag spikes using DX11 either, but the fact that I have a DX10 graphics card means I can't really test if that's the problem or if it's something else with the post-process effect?

Anyways, I just wanted to point that out to you, to see if maybe you had an answer for that behavior?  It could also be something with my settings in 5.0, so I'll continue to look at it. 

Thanks Aren!

ArenMook

  • Administrator
  • Hero Member
  • *****
  • Thank You
  • -Given: 337
  • -Receive: 1171
  • Posts: 22,128
  • Toronto, Canada
    • View Profile
Re: Tasharen Fog of War Unity 5.0 Question
« Reply #1 on: November 17, 2014, 08:34:20 AM »
Yeah... I wouldn't know about that.

Velo

  • Newbie
  • *
  • Thank You
  • -Given: 1
  • -Receive: 2
  • Posts: 13
    • View Profile
Re: Tasharen Fog of War Unity 5.0 Question
« Reply #2 on: November 17, 2014, 10:35:20 AM »
Aight.