Author Topic: Unity 4.6.2  (Read 2309 times)

voncarp

  • Jr. Member
  • **
  • Thank You
  • -Given: 13
  • -Receive: 2
  • Posts: 91
    • View Profile
Unity 4.6.2
« on: February 13, 2015, 01:54:18 AM »
TNET doesn't seem to work with Unity 4.6.2 IL2CPP feature.  It works in the editor, but not on any iOS builds. It doesn't seem to want to connect or host.  Are you familiar with what Unity is trying to do?

In the Unity blog it states, "If your existing project depends on native plugins, you might need to upgrade them to a version that supports 64-bit iOS and IL2CPP."

I am not sure if this applies to TNET.  From what I've read on the blog, its supposed to help with performance.

http://blogs.unity3d.com/2015/01/29/unity-4-6-2-ios-64-bit-support/

As of now, I am back to Unity 4.6.1.

ldw-bas

  • Newbie
  • *
  • Thank You
  • -Given: 2
  • -Receive: 2
  • Posts: 32
    • View Profile
Re: Unity 4.6.2
« Reply #1 on: February 13, 2015, 04:42:41 AM »
I have not taken a look at the TNET code but my guess is that is has to do with:

"Delegate BeginInvoke/EndInvoke will not work though other delegate functions are working well. We will address this in an upcoming patch release."

So next patch of unity it probably works.

ArenMook

  • Administrator
  • Hero Member
  • *****
  • Thank You
  • -Given: 337
  • -Receive: 1171
  • Posts: 22,128
  • Toronto, Canada
    • View Profile
Re: Unity 4.6.2
« Reply #2 on: February 13, 2015, 09:22:31 AM »
IL2CPP is still in beta stages. Few things work with it from what I hear.