Author Topic: "Hide Input" issue with Asian languages  (Read 4868 times)

Tashkent

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Posts: 9
    • View Profile
"Hide Input" issue with Asian languages
« on: March 03, 2015, 08:24:59 PM »
Hello,

I would like to change the way users input text on my Android game by hiding the input. However, when I check the “Hide Input” box, I cannot input text in Chinese, Japanese, Korean, or Thai. I type the characters but nothing appears in the text box. I also cannot input some special characters like a star or a heart (★,♥).

Many of my users are using these languages so it’s an important issue for me. Please let me know how to solve this.

Thank you

ArenMook

  • Administrator
  • Hero Member
  • *****
  • Thank You
  • -Given: 337
  • -Receive: 1171
  • Posts: 22,128
  • Toronto, Canada
    • View Profile
Re: "Hide Input" issue with Asian languages
« Reply #1 on: March 05, 2015, 09:49:45 PM »
Well, does the bitmap font used by the input field actually contain the characters you are trying to use? That would be the first thing to check. Also make sure the field isn't set to some validation method, such as "name".

Tashkent

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Posts: 9
    • View Profile
Re: "Hide Input" issue with Asian languages
« Reply #2 on: March 06, 2015, 12:29:49 AM »
Thank you for your answer.

I used the “NanumBarunGothic” dynamic font which includes Korean, Chinese and Japanese characters.

The validation method is set to “none” and is allowed for all keyboards.

Thank you.

ArenMook

  • Administrator
  • Hero Member
  • *****
  • Thank You
  • -Given: 337
  • -Receive: 1171
  • Posts: 22,128
  • Toronto, Canada
    • View Profile
Re: "Hide Input" issue with Asian languages
« Reply #3 on: March 10, 2015, 07:30:13 PM »
So you're using a dynamic font, not a bitmap font? Does it work if you don't hide input?

Tashkent

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Posts: 9
    • View Profile
Re: "Hide Input" issue with Asian languages
« Reply #4 on: March 11, 2015, 08:20:28 PM »
I do use a dynamic font and yes, it works with all languages when I don't use the "hide input" option.

Thank you

ArenMook

  • Administrator
  • Hero Member
  • *****
  • Thank You
  • -Given: 337
  • -Receive: 1171
  • Posts: 22,128
  • Toronto, Canada
    • View Profile
Re: "Hide Input" issue with Asian languages
« Reply #5 on: March 12, 2015, 08:26:00 PM »
Sounds like a Unity bug. NGUI uses TouchScreenKeyboard.text if it's available, Input.inputString otherwise. Check UIInput.cs, around line 670.

Tashkent

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Posts: 9
    • View Profile
Re: "Hide Input" issue with Asian languages
« Reply #6 on: March 16, 2015, 12:35:02 AM »
I changed UIInput.cs (line 669) as below:

Before -> string text = mKeyboard.text;
After -> string text = Input.inputString;

Before the change, the alphanumeric input was ok. After the change, I couldn’t type any character including alphanumeric.

markofevil3

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Posts: 25
    • View Profile
Re: "Hide Input" issue with Asian languages
« Reply #7 on: May 02, 2015, 10:14:40 AM »
I got the same problem, if turn off hide input, it works fine. If use hide input, the asian characters will not correct. Is there any walk-around for this? im using Unity 5.0f1, NGUI 3.8.2

ArenMook

  • Administrator
  • Hero Member
  • *****
  • Thank You
  • -Given: 337
  • -Receive: 1171
  • Posts: 22,128
  • Toronto, Canada
    • View Profile
Re: "Hide Input" issue with Asian languages
« Reply #8 on: May 02, 2015, 10:07:45 PM »
It's a Unity issue, so nope. You have to get them to fix it.