Author Topic: version 2.1.0 RFC issue  (Read 3193 times)

Eskinto

  • Newbie
  • *
  • Thank You
  • -Given: 1
  • -Receive: 0
  • Posts: 6
    • View Profile
version 2.1.0 RFC issue
« on: June 10, 2015, 09:49:38 AM »
Hello,

I've found an issue/bug when upgrading from Tnet v2.0.4 to the latest v2.1.0, suddenly none of my RFC calls get called, I get no warning/error on the console, and it seems to happen only when not connected to a server

tested on both Unity 5.0.2, and 5.1

Edit: I can replicate it just by opening a new project, importing Tnet 2.1.0, opening "Tnet/Examples/Scenes/Example 1" and clicking on the cubes, nothing happens on 2.1.0, works fine on 2.0.4
« Last Edit: June 10, 2015, 10:02:39 AM by Eskinto »

justinISO

  • Jr. Member
  • **
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Posts: 52
    • View Profile
Re: version 2.1.0 RFC issue
« Reply #1 on: June 10, 2015, 12:11:51 PM »
I am seeing the same issue.

ArenMook

  • Administrator
  • Hero Member
  • *****
  • Thank You
  • -Given: 337
  • -Receive: 1171
  • Posts: 22,128
  • Toronto, Canada
    • View Profile
Re: version 2.1.0 RFC issue
« Reply #2 on: June 11, 2015, 07:01:20 AM »
I will look into it, thanks.

justinISO

  • Jr. Member
  • **
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Posts: 52
    • View Profile
Re: version 2.1.0 RFC issue
« Reply #3 on: June 11, 2015, 01:45:13 PM »
Thank you, in the meantime is there a way I can get a copy of 2.0.4 so I can continue work until it is fixed?

Thanks,
Justin

ArenMook

  • Administrator
  • Hero Member
  • *****
  • Thank You
  • -Given: 337
  • -Receive: 1171
  • Posts: 22,128
  • Toronto, Canada
    • View Profile
Re: version 2.1.0 RFC issue
« Reply #4 on: June 11, 2015, 02:47:07 PM »
Just grab the 2.1.0b update, it should already be fixed.

justinISO

  • Jr. Member
  • **
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Posts: 52
    • View Profile
Re: version 2.1.0 RFC issue
« Reply #5 on: June 11, 2015, 03:58:44 PM »
I tried that and it still does not seem to be working. Tried just using the chat example also and that didn't seem to work either.

ArenMook

  • Administrator
  • Hero Member
  • *****
  • Thank You
  • -Given: 337
  • -Receive: 1171
  • Posts: 22,128
  • Toronto, Canada
    • View Profile
Re: version 2.1.0 RFC issue
« Reply #6 on: June 12, 2015, 08:10:54 AM »
Are you sure you have the B version? I'm trying it on my end and it works as expected. Starting the scene directly (in offline mode) and clicking on cubes changes their color.

justinISO

  • Jr. Member
  • **
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Posts: 52
    • View Profile
Re: version 2.1.0 RFC issue
« Reply #7 on: June 12, 2015, 10:32:37 AM »
I am sure I have the B version. I can confirm that example one is working for me however, my code is still not working.
Is there something glaringly obvious I am missing?

  1. using UnityEngine;
  2. using TNet;
  3.  
  4. public class SendScore : MonoBehaviour
  5. {
  6.  
  7.         public TNObject tno;
  8.  
  9.         public void Send ()
  10.         {
  11.                 Debug.Log ("Sending message");
  12.                 //MasterScript.master.myScore is an NGUI UILabel
  13.                 tno.Send ("OnScore", Target.All, TNManager.playerID, MasterScript.master.myScore.text);
  14.         }
  15.        
  16.        
  17.         [RFC] void OnScore (int playerID, string score)
  18.         {
  19.                 Debug.Log ("Message received");
  20.                 if (playerID != TNManager.playerID) {
  21.                         MasterScript.master.otherScore.text = score;
  22.                 }
  23.         }
  24.        
  25. }

The debug says "Sending Message" however, I never see "Message received".

ArenMook

  • Administrator
  • Hero Member
  • *****
  • Thank You
  • -Given: 337
  • -Receive: 1171
  • Posts: 22,128
  • Toronto, Canada
    • View Profile
Re: version 2.1.0 RFC issue
« Reply #8 on: June 12, 2015, 04:05:38 PM »
You need to derive your script from TNBehaviour, not MonoBehaviour. "tno" is already a part of TNBehaviour.