Author Topic: RESOLVED : Problem with UILabel not showing some special characters  (Read 4309 times)


  • Jr. Member
  • **
  • Thank You
  • -Given: 10
  • -Receive: 0
  • Posts: 56
    • View Profile
I'm using NGUI's built in localisation system, but I'm having some problems in the editor with some of the special characters not showing in my UILabel.

For instance the French phrase 'RESTEZ À L'AFFÛT' when I run the game is showing on the label at runtime as RESTEZ � L'AFF�T
So some of the characters are replaced with a question mark in a diamond.

You can see an example image here...

The font definately has those characters in its set of glyphs, so that is not the issue.

In fact if I go and paste the word from the text file onto the label at runtime, it then shows correctly in the editor?
Why would it show the incorrect version first, then allow the correct value to be pasted manually?

I've tried both Unity and NGUI font options, the Unity Font option shows the question marks, the NGUI font option just doesn't render a character at all.

Any ideas why this is happening or a way to fix it?
I'm on v3.11.4


Solved : I opened the .txt files in NotePad++

All works well now.

« Last Edit: January 11, 2018, 03:53:49 AM by Meltdown »