Author Topic: 7 Script errors with NGUI 2.3.6a  (Read 3162 times)

Crazy Robot Games

  • Guest
7 Script errors with NGUI 2.3.6a
« on: March 11, 2013, 01:57:53 PM »
I just downloaded NGUI 2.3.6a unto a new Unity 4 project and now have 7 hard script errors:


Assets/NGUI/Scripts/Interaction/UICenterOnChild.cs(11,28): error CS0426: The nested type `OnFinished' does not exist in the type `SpringPanel'

Assets/NGUI/Scripts/Tweening/TweenAlpha.cs(55,33): error CS0115: `TweenAlpha.OnUpdate(float, bool)' is marked as an override but no suitable method found to override


Assets/NGUI/Scripts/Tweening/TweenFOV.cs(24,33): error CS0115: `TweenFOV.OnUpdate(float, bool)' is marked as an override but no suitable method found to override


Assets/NGUI/Scripts/UI/UIFilledSprite.cs(189,30): error CS0115: `UIFilledSprite.OnFill(BetterList<UnityEngine.Vector3>, BetterList<UnityEngine.Vector2>, BetterList<UnityEngine.Color>)' is marked as an override but no suitable method found to override



Assets/NGUI/Scripts/UI/UISlicedSprite.cs(116,30): error CS0115: `UISlicedSprite.OnFill(BetterList<UnityEngine.Vector3>, BetterList<UnityEngine.Vector2>, BetterList<UnityEngine.Color>)' is marked as an override but no suitable method found to override


Assets/NGUI/Scripts/UI/UITexture.cs(48,30): error CS0115: `UITexture.OnFill(BetterList<UnityEngine.Vector3>, BetterList<UnityEngine.Vector2>, BetterList<UnityEngine.Color>)' is marked as an override but no suitable method found to override


Assets/NGUI/Scripts/UI/UITiledSprite.cs(47,30): error CS0115: `UITiledSprite.OnFill(BetterList<UnityEngine.Vector3>, BetterList<UnityEngine.Vector2>, BetterList<UnityEngine.Color>)' is marked as an override but no suitable method found to override


Crazy Robot Games

  • Guest
Re: 7 Script errors with NGUI 2.3.6a
« Reply #1 on: March 11, 2013, 02:02:03 PM »
Ok, I just deleted NGUI and reinstalled it.

No errors, but then I installed NGUI HUD Text 1.6a and that's when I get all the errors.

Nicki

  • Global Moderator
  • Hero Member
  • *****
  • Thank You
  • -Given: 33
  • -Receive: 141
  • Posts: 1,768
    • View Profile
Re: 7 Script errors with NGUI 2.3.6a
« Reply #2 on: March 11, 2013, 02:05:41 PM »
I think Hud Text overwrites with its own free version of NGUI. When you import Hud Text, don't import the NGUI core files.