Author Topic: Can't select any atlas images in Widget Tool (Solved)  (Read 2027 times)

masterhyjinx

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Posts: 29
    • View Profile
Can't select any atlas images in Widget Tool (Solved)
« on: August 10, 2013, 04:53:54 AM »
I'm having an odd issue I can't figure out and I don't see it posted anywhere.  I cannot select any images to use in the Widget Tool when creating widgets.  I've created my UI, set up layers and tagged the appropriate items.  I created an atlas and when I go to the widget tool, select progress bar (or anything where you pick the image) and when I click the drop downs, nothing drops down.  I've tried recreating the atlases, re-installing NGUI and Unity.  I even opened the example scenes and attempted to create new widgets there and those are broken in the same way.  The following images show what I mean.  One field says "Dark" but I can't change it (Using the Sci Fi atlas) and the other field is blank.  If I click either one, nothing happens.

I rolled back to a project using NGUI 2.6.2 where I knew it was working and it's the same issue.  Is this a problem with Unity 4.2?  I'm going to try to boot my broken laptop and try on that.

I have Unity 4.2 and NGUI 2.6.4 running on OS X.
« Last Edit: August 10, 2013, 05:02:05 AM by masterhyjinx »

masterhyjinx

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Posts: 29
    • View Profile
Re: Can't select any atlas images in Widget Tool (Solved)
« Reply #1 on: August 10, 2013, 05:01:42 AM »
Of course it occurs to me AFTER I post that perhaps I should unplug my Oculus Rift.  It IS off but I wonder if... oh son of a.  The texture picking window was popping up on my Oculus rift display (That wasn't even on) and not on my other two monitors I was actually using.  Nothing to see here people.  Sorry about the post.

ArenMook

  • Administrator
  • Hero Member
  • *****
  • Thank You
  • -Given: 337
  • -Receive: 1171
  • Posts: 22,128
  • Toronto, Canada
    • View Profile
Re: Can't select any atlas images in Widget Tool (Solved)
« Reply #2 on: August 10, 2013, 10:49:20 AM »
There is no issue here. Just re-select your sprite.

The sprite being empty like that simply means that whatever sprite it was using before no longer exists -- whether by switching projects, or by simply removing it.