Author Topic: Panel Alpha Clipping bug [RESOLVED]  (Read 2398 times)

Ana

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Posts: 28
    • View Profile
Panel Alpha Clipping bug [RESOLVED]
« on: November 08, 2013, 04:44:26 PM »
I have had a problem since I've started using NGUI that just wont go away. It always happens without fail. I've followed tutorials on how to make a panel with alpha clipping and it works IF there is no slider. If I try to drag the slider the clipping re positions itself so it has -width/2 as center of the clipping area for no reason.
I even tried to update to the newest version hoping you fixed it (even though I've done the whole project in the version before 3 so upgrading is painful) to no avail. So I recorded a video of what happens:
http://youtu.be/lPt_dEwYKlk
It is driving me crazy, I can't have sliders or all my panels break! If I click reposition clipping in draggable panel the same thing happens. There is no reason reposition should do this!
Here is a screenshot of my panel settings, though I've tried adjusting every setting available to get it to work and the same thing happens.
If you have any questions (and I'm sure you will have) please ask. It is a show stopper for my project and I want it fixed ASAP.
« Last Edit: November 09, 2013, 07:27:29 PM by Ana »

ArenMook

  • Administrator
  • Hero Member
  • *****
  • Thank You
  • -Given: 337
  • -Receive: 1171
  • Posts: 22,128
  • Toronto, Canada
    • View Profile
Re: Panel Alpha Clipping bug
« Reply #1 on: November 09, 2013, 07:44:13 AM »
I've never seen that happen, and looking at your setup I don't see anything obviously wrong. Have you looked at what's different between your setup and the quest log example? If you can't figure it out, you can upload your project somewhere and send me a link, and I will have a look. Just don't post the link here. Use email -- support at tasharen.com.

Ana

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Posts: 28
    • View Profile
Re: Panel Alpha Clipping bug
« Reply #2 on: November 09, 2013, 04:33:03 PM »
Sent an email with an empty project demonstrating the bug.

ArenMook

  • Administrator
  • Hero Member
  • *****
  • Thank You
  • -Given: 337
  • -Receive: 1171
  • Posts: 22,128
  • Toronto, Canada
    • View Profile
Re: Panel Alpha Clipping bug
« Reply #3 on: November 09, 2013, 07:17:00 PM »
Found your issue. You need to specify a width for your panel. You left the X size at zero, and with "relative position on reset" being top left corner (0, 0), the panel was always getting reset to be based off the top-left, which happened to be off to the side.

Giving it a width of 600 fixed the problem.

Ana

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Posts: 28
    • View Profile
Re: Panel Alpha Clipping bug
« Reply #4 on: November 09, 2013, 07:26:59 PM »
I left it at 0 because I thought if left at 0 it would default to size of the panel because it seemed to behave that way in the editor. It's a subtle bug, maybe you should set a warning in the next NGUI update if panel clipping is set to 0?

Anyway, thank you! Now I can finally add those scrollbars :)