Author Topic: Upgrading 2.0.1B exception  (Read 4125 times)

Alex

  • Guest
Upgrading 2.0.1B exception
« on: April 16, 2012, 07:52:02 AM »
Hi,
I upgrade NGUI to 2.0.1 and i get this exception:
Scene is being destroyed while there are hidden renderers that are using it. This is likely an editor script creating objects with hideFlags and leaving them enabled.

Help please.

yuewah

  • Full Member
  • ***
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Posts: 180
    • View Profile
Re: Upgrading 2.0.1B exception
« Reply #1 on: April 16, 2012, 08:00:37 AM »
It also happen on NGUI 2.0.0 + Unity 3.5.1

joreldraw

  • Guest
Re: Upgrading 2.0.1B exception
« Reply #2 on: April 16, 2012, 08:26:31 AM »
In my project im on NGUI 1.91 and work fine with Unity 3.5.1f2

ArenMook

  • Administrator
  • Hero Member
  • *****
  • Thank You
  • -Given: 337
  • -Receive: 1171
  • Posts: 22,128
  • Toronto, Canada
    • View Profile
Re: Upgrading 2.0.1B exception
« Reply #3 on: April 16, 2012, 09:40:43 AM »
I need more details on where it's happening. Can you reproduce it on any of the examples?

Alex

  • Guest
Re: Upgrading 2.0.1B exception
« Reply #4 on: April 16, 2012, 09:53:50 AM »
Hi,
The only thing i did is this:
1.delete NGUI 2.0.0b
2.download new NGUI ( 2.0.1b )
3.and then the problem appear in all of my scenes.

When i quit unity and then restart it again, the problem are gone.
hope it helps.

ArenMook

  • Administrator
  • Hero Member
  • *****
  • Thank You
  • -Given: 337
  • -Receive: 1171
  • Posts: 22,128
  • Toronto, Canada
    • View Profile
Re: Upgrading 2.0.1B exception
« Reply #5 on: April 16, 2012, 09:55:08 AM »
Sounds like you didnt do Start -> New Scene prior to deleting NGUI and importing the update?

Alex

  • Guest
Re: Upgrading 2.0.1B exception
« Reply #6 on: April 16, 2012, 10:07:09 AM »
You right, i didn't know i should make a new scene before deleting NGUI and updating it.
I'll try to memorize it next time :)

rain

  • Jr. Member
  • **
  • Thank You
  • -Given: 2
  • -Receive: 4
  • Posts: 79
    • View Profile
Re: Upgrading 2.0.1B exception
« Reply #7 on: April 17, 2012, 10:01:27 AM »
Hi!
I'm experiencing the same problem, i updated the NGUI while having my main project open.
Now this error message keeps coming up when i stop the editor play mode.
How can I get rid of it?  :D

ArenMook

  • Administrator
  • Hero Member
  • *****
  • Thank You
  • -Given: 337
  • -Receive: 1171
  • Posts: 22,128
  • Toronto, Canada
    • View Profile
Re: Upgrading 2.0.1B exception
« Reply #8 on: April 17, 2012, 06:10:24 PM »
Follow the proper update instructions to get rid of it.