Author Topic: Discrepancy between scenes with new anchoring system  (Read 6340 times)

Seith

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Posts: 37
    • View Profile
    • SeithCG
Re: Discrepancy between scenes with new anchoring system
« Reply #15 on: December 31, 2013, 02:16:51 PM »
I've just updated to 3.0.8f3 but the problem is still present.
SeithCG.com

ArenMook

  • Administrator
  • Hero Member
  • *****
  • Thank You
  • -Given: 337
  • -Receive: 1171
  • Posts: 22,128
  • Toronto, Canada
    • View Profile
Re: Discrepancy between scenes with new anchoring system
« Reply #16 on: December 31, 2013, 03:41:11 PM »
Alright, in that case I will need a simple repro case. If you can create a scene using the example atlases and send it to support at tasharen.com, I'll have a look. Just please don't upload it here.

Seith

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Posts: 37
    • View Profile
    • SeithCG
Re: Discrepancy between scenes with new anchoring system
« Reply #17 on: January 05, 2014, 11:12:31 AM »
For anyone meeting the same behavior: It would seem Unity's own Water 4 prefab is the culprit. There is an automatic camera created for the water reflections and that camera insists on having the "UI" layer (used by NGUI) in its culling mask. This is what causes the problem I'm encountering.

I've communicated the info to ArenMook to see if he can reproduce the issue on his side...
SeithCG.com

Seith

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Posts: 37
    • View Profile
    • SeithCG
Re: Discrepancy between scenes with new anchoring system
« Reply #18 on: January 06, 2014, 11:43:59 AM »
Alright, the solution for my problem turns out to be that my main camera didn't have a "UICamera" script component attached. Once I did that, NGUI was able to correctly identify the main game camera (ignoring the water reflection camera) and there was much rejoicing...

Thanks again for your help ArenMook!
SeithCG.com