Author Topic: [Solved]Scrollview and Scrollbar issue on startup  (Read 2245 times)

rain

  • Jr. Member
  • **
  • Thank You
  • -Given: 2
  • -Receive: 4
  • Posts: 79
    • View Profile
[Solved]Scrollview and Scrollbar issue on startup
« on: February 04, 2014, 12:19:26 PM »
Hi!

I've encountered an issue where a ScrollView would not start in its intended position (0,0,0) but "scrolled down" by ~300 units, but only if a UIScrollBar is assigned to it.

What could be going wrong here?

Thanks in advance.
« Last Edit: February 06, 2014, 09:56:51 AM by rain »

pad406

  • Jr. Member
  • **
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Posts: 62
    • View Profile
Re: Scrollview and Scrollbar issue on startup
« Reply #1 on: February 04, 2014, 04:36:58 PM »
Sounds like may be the same, or very similar issue to what I was having. See this post http://www.tasharen.com/forum/index.php?topic=7899.0

rain

  • Jr. Member
  • **
  • Thank You
  • -Given: 2
  • -Receive: 4
  • Posts: 79
    • View Profile
Re: Scrollview and Scrollbar issue on startup
« Reply #2 on: February 05, 2014, 04:57:28 AM »
I've read that topic, but changing the script execution order didn't fix it for me and also my panels aren't marked as static.

Thanks anyways!

ArenMook

  • Administrator
  • Hero Member
  • *****
  • Thank You
  • -Given: 337
  • -Receive: 1171
  • Posts: 22,128
  • Toronto, Canada
    • View Profile
Re: Scrollview and Scrollbar issue on startup
« Reply #3 on: February 05, 2014, 02:47:39 PM »
Scroll view will attempt to move only if the children happen to lie outside of it, and are not taking advantage of the space within. So if your starting position has space on one side of the scroll view, and items extend past the border of another, then it will attempt to fix that. Can you post a pic of what your initial startup looks like in the scene view?

rain

  • Jr. Member
  • **
  • Thank You
  • -Given: 2
  • -Receive: 4
  • Posts: 79
    • View Profile
Re: Scrollview and Scrollbar issue on startup
« Reply #4 on: February 06, 2014, 09:56:14 AM »
I got it fixed somehow by completely rearranging the anchoring of my widgets and the scrollview. Dunno what exactly did the job but whatevs, it works now.  :D