Author Topic: Recently Updated, now nothing works properly  (Read 2067 times)

noahg1

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Posts: 4
    • View Profile
Recently Updated, now nothing works properly
« on: March 27, 2014, 12:29:20 PM »
Hi all,

I just updated and re-imported the NGUI assets, and now nothing seems to work properly.
My main menu shows the outline of where my widgets should be but does not show them in the scene nor game view.
Also my HUDs, are all out of proportion. Many of widgets are no longer lined up as they should be.
Finally, I can no longer make UICheckbox variables in script, so I cant access whether the checkbox is checked anymore, however I can still access UILabel. (error CS0246: The type or namespace name `UICheckbox' could not be found. Are you missing a using directive or an assembly reference?) It turns our, UICHeckbox is now called UIToggle.

Maybe I am doing something silly and its any easy fix, any help would be greatly appreciated because I am really reluctant to redo my entire UI.
« Last Edit: March 27, 2014, 12:42:13 PM by noahg1 »

rain

  • Jr. Member
  • **
  • Thank You
  • -Given: 2
  • -Receive: 4
  • Posts: 79
    • View Profile
Re: Recently Updated, now nothing works properly
« Reply #1 on: March 27, 2014, 12:38:33 PM »
I guess you didn't delete the NGUI folder before updating and reimporting it.

noahg1

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Posts: 4
    • View Profile
Re: Recently Updated, now nothing works properly
« Reply #2 on: March 27, 2014, 12:41:28 PM »
Opened a new scene, deleted the NGUI folder form the project view, then I went to the asset store, updated, downloaded then imported the package.

ArenMook

  • Administrator
  • Hero Member
  • *****
  • Thank You
  • -Given: 337
  • -Receive: 1171
  • Posts: 22,128
  • Toronto, Canada
    • View Profile
Re: Recently Updated, now nothing works properly
« Reply #3 on: March 27, 2014, 07:59:53 PM »
Which version did you update from? UICheckbox suggests pre-3.0, and NGUI 2 to NGUI 3 can be a difficult upgrade -- which is why there is a video on it.

noahg1

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Posts: 4
    • View Profile
Re: Recently Updated, now nothing works properly
« Reply #4 on: March 30, 2014, 05:25:12 PM »
Thank you. I see a lot has changed. I have not upgrade probably for 5 months or more, that is why I'm running an older version.

I think I will just use this to force me to take the time and redesign my GUI system. :)  I will check out the video anyways.