Author Topic: Issue with NGUI 3.5.9  (Read 1952 times)

nah0y

  • Sr. Member
  • ****
  • Thank You
  • -Given: 1
  • -Receive: 2
  • Posts: 430
  • \o/
    • View Profile
Issue with NGUI 3.5.9
« on: May 15, 2014, 08:33:06 AM »
In UIDrawCall.cs line 292 there is:
  1. #if !UNITY_3_5
  2.         string[] keywords = mMaterial.shaderKeywords;
  3.         for (int i = 0; i < keywords.Length; ++i)
  4.                 mDynamicMat.EnableKeyword(keywords[i]);
  5. #endif
  6.  

But EnableKeyword is not available in Unity 4.1.2 so there's an error.
Of course if you don't want to support 4.1.2 that's your choice, but on Twitter you said you would drop support in the NEXT release, not this one :)
I have removed these lines for now.

ArenMook

  • Administrator
  • Hero Member
  • *****
  • Thank You
  • -Given: 337
  • -Receive: 1171
  • Posts: 22,128
  • Toronto, Canada
    • View Profile
Re: Issue with NGUI 3.5.9
« Reply #1 on: May 15, 2014, 11:23:08 AM »
I said I'll support 3.5.7, not 4.1 :P

I can't have so many versions of Unity installed here and test with them all.

Change that statement to #if !UNITY_3_5 && !UNITY_4_1 && !UNITY_4_2

nah0y

  • Sr. Member
  • ****
  • Thank You
  • -Given: 1
  • -Receive: 2
  • Posts: 430
  • \o/
    • View Profile
Re: Issue with NGUI 3.5.9
« Reply #2 on: May 15, 2014, 11:27:02 AM »
Yes, this must be a pain in the ass to test...
Should have a bash script that will open a demo project in every Unity version you have and run a sall test :)

ArenMook

  • Administrator
  • Hero Member
  • *****
  • Thank You
  • -Given: 337
  • -Receive: 1171
  • Posts: 22,128
  • Toronto, Canada
    • View Profile
Re: Issue with NGUI 3.5.9
« Reply #3 on: May 15, 2014, 11:28:42 AM »
This is why NGUI 3.6.0 will require Unity 4.3.4 or higher. I am tired of hacks and ifdefs all over the place.