Author Topic: Tasharen Water  (Read 104741 times)

O4karitO

  • Guest
Re: Tasharen Water
« Reply #75 on: October 01, 2013, 01:08:43 PM »
But if the standard material shader which is used doesn't do this what should i do to receive foam? How should I modify it for foam to appear?
Thanks
« Last Edit: October 02, 2013, 03:57:12 AM by O4karitO »

ArenMook

  • Administrator
  • Hero Member
  • *****
  • Thank You
  • -Given: 337
  • -Receive: 1171
  • Posts: 22,128
  • Toronto, Canada
    • View Profile
Re: Tasharen Water
« Reply #76 on: October 03, 2013, 04:48:07 AM »
Standard material shader for what? For your objects? Then yes. Try making a simple cube (GameObject -> Create Other -> Cube) and placing it partially submerged in water. You will see foam because it uses a depth-writing shader.

O4karitO

  • Guest
Re: Tasharen Water
« Reply #77 on: October 03, 2013, 11:15:39 AM »
Standard material shader for what? For your objects? Then yes. Try making a simple cube (GameObject -> Create Other -> Cube) and placing it partially submerged in water. You will see foam because it uses a depth-writing shader.
Just checked, there is no foam.

ArenMook

  • Administrator
  • Hero Member
  • *****
  • Thank You
  • -Given: 337
  • -Receive: 1171
  • Posts: 22,128
  • Toronto, Canada
    • View Profile
Re: Tasharen Water
« Reply #78 on: October 04, 2013, 02:59:25 AM »
What quality settings are you running it on? If you have the lowest quality (mobile), then there is no foam, and no soft edges. All other qualities will feature foam.

O4karitO

  • Guest
Re: Tasharen Water
« Reply #79 on: October 04, 2013, 09:14:18 AM »
Medium quality. There is a foam around the terrain only.By the way I didn't see the foam around other objects in this plugin preview or in WindWard.

jRocket

  • Guest
Re: Tasharen Water
« Reply #80 on: October 04, 2013, 05:21:36 PM »
In regard to the foam not showing up, I had that problem too with smaller objects. Its probably there but you don't notice it. Try adjusting the inverse alpha value and/or increase the tiling value in the material(or use a different foam texture). I feel that the foam should be a separate texture(not in the alpha of the normal map) or have its own tiling.

My unrelated problem- Using my custom normal map doesn't seem to work well. The stock Unity water normal map also doesn't work well. If you use the normal map from the stock unity water, there are black splotches everywhere. Is there anything special about the Tasharen Water normal map that would cause it to work better? 

ArenMook

  • Administrator
  • Hero Member
  • *****
  • Thank You
  • -Given: 337
  • -Receive: 1171
  • Posts: 22,128
  • Toronto, Canada
    • View Profile
Re: Tasharen Water
« Reply #81 on: October 04, 2013, 08:38:56 PM »
Yes, Tasharen Water normal map is not a "normal map", in Unity's terms. It's a truecolor texture. RGB channels have a normal map in it, while the Alpha channel has the foam texture. Unity's version of normal maps are compressed textures that don't have an alpha channel, so they are not suitable.

tankun

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Posts: 4
    • View Profile
Re: Tasharen Water
« Reply #82 on: December 16, 2013, 03:40:53 AM »
Hi,

I'd like to ask you about the reflection distance of the mesh objects on water. They disappear as the distance from the water increases but I couldn't find way to adjust the distance. Also somehow this distance is varied. I've attached the pictures here. As you can see, the reflection looks great in the closeup image, as we go far from the object, reflections disappear. Then all of a sudden, they appear as we go further again. It seems to be an issue with the looking angle I guess. As you look more from above, the reflections appear even if you are really far from the object. Is there way to keep the reflections consistent regardless of the viewing angle?

Thanks

Tan

ArenMook

  • Administrator
  • Hero Member
  • *****
  • Thank You
  • -Given: 337
  • -Receive: 1171
  • Posts: 22,128
  • Toronto, Canada
    • View Profile
Re: Tasharen Water
« Reply #83 on: December 16, 2013, 09:22:26 AM »
Double-check which layers your water reflects. It should not reflect itself.

tankun

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Posts: 4
    • View Profile
Re: Tasharen Water
« Reply #84 on: December 16, 2013, 02:56:34 PM »
I checked the layers, it's not reflecting itself (which is the "water" layer by default anyway). In fact I tried to reflect everything including the water level to jinx it but result was interestingly the same.

Actually I figured out the reason but couldn't find a solution. It's got something to do with the baked occlusion culling. When you clear the occlusion map the problem goes away. I'm trying to play around with the occlusion culling settings to sort out this issue. For instance if the occlusion culling area is as big as the tasharen water mesh, the problem worsens; the water reflections from the regular meshes disappear completely. Sky reflection is always there by the way (I'm using the high shader setting). It's never effected by this issue.

ArenMook

  • Administrator
  • Hero Member
  • *****
  • Thank You
  • -Given: 337
  • -Receive: 1171
  • Posts: 22,128
  • Toronto, Canada
    • View Profile
Re: Tasharen Water
« Reply #85 on: December 16, 2013, 05:13:11 PM »
Ah yes, occlusion checks would indeed break it. Occlusion feature is meant for indoor scenes, not for outdoor environments (and especially not reflected outdoor environments!)

tankun

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Posts: 4
    • View Profile
Re: Tasharen Water
« Reply #86 on: December 17, 2013, 12:42:53 AM »
I see, ok thanks. I'll try to find a workaround. Fiddling with the occlusion area size might help.

edit: Well, it didn't. As I said in my earlier post, it doesn't break the reflection completely but only from certain angles. So I believe if there was a way in the shader to adjust the reflection settings somehow, I'm sure there would be a nice soft spot where reflection would work for certain purposes. For instance in my game, we see the ocean from one certain angle only, and that's the angle where the reflection is absent.

PS: I respectfully disagree with the occlusion feature being meant only for indoors by the way; but it's another days topic :)
« Last Edit: December 17, 2013, 01:07:46 AM by tankun »

ArenMook

  • Administrator
  • Hero Member
  • *****
  • Thank You
  • -Given: 337
  • -Receive: 1171
  • Posts: 22,128
  • Toronto, Canada
    • View Profile
Re: Tasharen Water
« Reply #87 on: December 17, 2013, 12:39:22 PM »
Let me put it this way... From what I've seen, Unity didn't expect occlusion checks to be reflected. That's why it breaks. But if you figure out some way to make them play along nicely, let me know. :)

tankun

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Posts: 4
    • View Profile
Re: Tasharen Water
« Reply #88 on: December 18, 2013, 01:59:34 AM »
Will do, thanks.

Flasheart

  • Newbie
  • *
  • Thank You
  • -Given: 1
  • -Receive: 0
  • Posts: 4
    • View Profile
Re: Tasharen Water
« Reply #89 on: January 18, 2014, 11:13:08 AM »
Hi guys,,, very new to unity, and looking at many packages mostly as a learning tool...  Just purchased Tasharen Water, and the multi-purpose game starter kit... also have added NGUI and Playmaker packages in a new project....

I get a fatal error and can't proceed... the error is coming from Tasharen Water....  "Assets/Tasharen/Water Example/Scripts/RandomGenerator.cs(4,14): error CS0101: The namespace `global::' already contains a definition for `RandomGenerator'" also getting a warning from the MPGSK "Shader wants normals, but the mesh Laser Beam doesn't have them
UnityEditor.AssetPreviewUpdater:CreatePreviewForAsset(Object, Object[], String)" . any help or suggestions would be appreciated... thanks guys. Using Unity 4.3.3f1.  Free version, latest build.