Author Topic: NGUI Elements Not Rendering  (Read 33 times)

BusterTFuzz

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Posts: 1
    • View Profile
NGUI Elements Not Rendering
« on: December 26, 2017, 09:55:39 PM »
Hi everyone,

I recently went back to an older project, and opened it in Unity 2017.1.1f1. It uses NGUI components.
When I opened the project not a single NGUI component would render. I went through a whole bunch of forum posting and
many of the items suggested switching layers, or enabling layers. Unfortunately none of that worked.

I was able to use native Unity3d UI elements and those were rendering. However, I would prefer to use my NGUI scene as it would
mean preserving a ton of work.

Description:

Game view shows nothing. No objects render. In Scene view, I see outlines of the game objects but not actual renderings.
I am enclosing screen grabs of everything. Hopefully someone will have some insights. I have tried everything.

I have enclosed my main camera settings, my scene view, my ui camera settings, and my UI root game object settings.

I also updated to the latest version of NGUI. (Problem occurred before this upgrade. Was hoping upgrade would cure it.)

I have tried everything to fix this. I have toggled layers off and on. I have made sure that all layers are enabled
Perhaps a fresh set of eyes will have some insight.

Thank you in advance. All help is appreciated.


-- UPDATE -- I found that if I add a material to each sprite, suddenly the graphics start to re-appear.
This makes more more confused. Why do I need to add a material. Also, this completely tosses alpha channel.


« Last Edit: December 26, 2017, 10:42:14 PM by BusterTFuzz »