Author Topic: NGUI not drawn anymore after update from 3.5.3 to 3.5.6  (Read 936 times)

Bradamante3D

  • Jr. Member
  • **
  • Thank You
  • -Given: 2
  • -Receive: 0
  • Posts: 79
    • View Profile
NGUI not drawn anymore after update from 3.5.3 to 3.5.6
« on: April 10, 2014, 02:31:15 PM »
Hi,

yeah, thread title says it all. I updated my project from 3.5.3 to 3.5.6 and now all NGUI elements are not drawn anymore (see screenshot). I have changed nothing else.

Checking things like camera draw masks or the material of the atlas (Unlit - Transparent Colored (AlphaClip)) shows nothing unusual.

Importing NGUI into an empty project and going through the example scenes, NGUI is drawn correctly as usual.

Any clue on what is going on here?

Unity 4.3.4f1. Mac OS X.9.1. CustoMac w/ GTX 650 Ti.

EDIT:
Nevermind. I tested the main menu scene and the GUI was there. Then going back to the main game scene the GUI was back there, too.
« Last Edit: April 10, 2014, 05:05:14 PM by Bradamante3D »
#301224014, #301432336, #302399130

tr4np

  • Newbie
  • *
  • Thank You
  • -Given: 2
  • -Receive: 0
  • Posts: 17
    • View Profile
Re: NGUI not drawn anymore after update from 3.5.3 to 3.5.6
« Reply #1 on: April 10, 2014, 02:39:53 PM »
It would help if you posted a screen shot containing these three things:

1. the hierarchy view with the camera selected
2. scene view
3. inspector view

ArenMook

  • Administrator
  • Hero Member
  • *****
  • Thank You
  • -Given: 337
  • -Receive: 1171
  • Posts: 22,154
  • Toronto, Canada
    • View Profile
Re: NGUI not drawn anymore after update from 3.5.3 to 3.5.6
« Reply #2 on: April 11, 2014, 07:11:55 AM »
The 3-step upgrade process in the Readme file is not optional. It's mandatory if you don't want things to break like this.