Author Topic: [Solved]Strange Android to PC connection problem  (Read 2150 times)

Krtsst

  • Newbie
  • *
  • Thank You
  • -Given: 1
  • -Receive: 0
  • Posts: 2
    • View Profile
[Solved]Strange Android to PC connection problem
« on: February 13, 2015, 02:38:36 PM »
Hello,

I've got very weird problem with TNet on android devices.
Basically, I run Example (Menu Example) form package, and on PC to PC it's working great(PC to Android server does work great too), but when I try connect Android device to PC server(of course i mean that LAN server from example) it doesn't work(Unable to connect).
But when I first start server on Andorid and make PC connects to that, and stop server on android then create server on PC suddenly Android can now connect to PC.
I tried different devices and different networks, so I guess it's not device or router/network related.
I could't find anything like that on this forum, so I decided to write a post. If there is a solution somewhere, a link to that would be nice.

I tried to discribe my problem as clearly, as I could with my poor english skill, sorry.

I'm looking forward for response.

Thanks in advance.
« Last Edit: February 14, 2015, 10:14:35 AM by Krtsst »

ArenMook

  • Administrator
  • Hero Member
  • *****
  • Thank You
  • -Given: 337
  • -Receive: 1171
  • Posts: 22,128
  • Toronto, Canada
    • View Profile
Re: Strange Android to PC connection problem
« Reply #1 on: February 14, 2015, 09:50:33 AM »
It's probably your firewall and/or antivirus software that's getting in the way by blocking parts/incoming connections.

Krtsst

  • Newbie
  • *
  • Thank You
  • -Given: 1
  • -Receive: 0
  • Posts: 2
    • View Profile
Re: Strange Android to PC connection problem
« Reply #2 on: February 14, 2015, 10:13:39 AM »
You're right!
I didn't take it into account but, on those different networks that I tried was same firewall/antivirus. Anyway, it's kind of strange.

Thank you very much, for solving my problem.